Results 1 to 3 of 3

Thread: Problem Gemini Cdj-02

  1. #1
    AH Listener KennedY's Avatar
    Join Date
    Nov 2009

    Problem Gemini Cdj-02

    Any1 help at all - cdj repair, my unit was set to the wrong voltage when turned on, was set at 115v and should have been 220v. Now when the unit is turned on is completely dead, I know I should have checked before turning on just presumed......Not be presuming again ever.....

    Any pointers guys and gals??

  2. #2
    Just got here baggler's Avatar
    Join Date
    Dec 2009
    internal fuse or power transformer damage most likely, may have even damaged other circuitry?????

  3. #3
    AH Listener KennedY's Avatar
    Join Date
    Nov 2009
    Thanks, checked the plug fuse but was'nt sure if the units have a internal fuse?? If they i will have to have a look. But thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gemini's Edge - Strange Love Out Now!
    By MihaiChristian in forum Music Discussion
    Replies: 3
    Last Post: Oct 30th, 2009, 07:03
  2. torrnet problem
    By soundr in forum Help & Support | Feedback
    Replies: 5
    Last Post: Jul 5th, 2008, 09:46
  3. sound card problem (help me)
    By Freddy12 in forum Equipment
    Replies: 13
    Last Post: May 16th, 2008, 11:26
  4. Problem z forum
    By Arczi in forum Hydepark
    Replies: 9
    Last Post: Oct 10th, 2007, 01:23
  5. DNS Problem?
    By jedrekmx in forum Help & Support | Feedback
    Replies: 6
    Last Post: Dec 21st, 2006, 09:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts