Results 1 to 5 of 5

Thread: Help for who is setting up DJM 2000 Nexus & CDJ 2000 Nexus as MIDI controller

  1. #1
    AH.FM Addict enRu's Avatar
    Join Date
    May 2010
    Gender
    Male
    Location
    Moving for free (requires Sun)
    Posts
    3,732

    Help for who is setting up DJM 2000 Nexus & CDJ 2000 Nexus as MIDI controller

    Wonderful piece of hardware I have, but every time I reinstall I spend a few hours figuring out the goddamn right config to be able to start mixing or even connecting it.

    For who is interested, here is how to get the combination of Pioneer DJM 2000 Nexus & CDJ 2000 Nexus working (on windows) + some tips to check what you might be overlooking.

    First you need to know you can use the DJM and CDJs with MIDI, network cables, USB, CDs, first I will talking about setting it up as MIDI controller (USB). This is not the same as pluggin USB keys with tracks on it or CDs to mix.

    OPTION 1: Using it as MIDI controller

    Note I use Traktor Pro in this guide

    1. You do not need LAN cables for setting it up as MIDI, purely leave it USB and audio (cinch or digital)

    2. Let's start with the players (CDJ 2000 Nexus)

    Download latest drivers
    http://pioneerdj.com/support
    Note if using Windows 7 it goes well, if using Windows 8/8.1, the driver is somehow not really trusted requiring extra action. Will be explained later.

    Once you have installed the driver, you have an entry "pioneer" in start - all programs, run "Pioneer CDJ ASIO Settings Utility"

    The best is to set it to 24 bit

    + Buffer max, to avoid CPU trouble while mixing (might cause interrupts etc)

    Also press utility button on the CDJ themselves and see if you have same bit rate set on the CDJs



    Make sure the playback on your volume playback (rightclick volume - playback devices - Find the CDJs) corresponds to the input audio cable you plug in and corresponds to the setting on the players themselves (both)


    Which cable you plugged where is depending the sound card you have
    (I plugged only the DJM to Blue - Line In, rest USB, nothing else)

    3. Next DJM

    I plugged REC OUT on DJM to Blue Line In on PC

    To hear it, make sure the cable you plugged also has volume on for your speakers playback (volume might be 0 so set it on)


    Get the DJM driver (same site of pioneer)
    Again in the Program files, find the DJM 2000 Settings utility

    If you want to record, select 1 input
    Again max buffer to avoid problems

    -will continue on next page-
    Last edited by enRu; Jul 4th, 2014 at 22:46.

  2. #2
    AH.FM Addict enRu's Avatar
    Join Date
    May 2010
    Gender
    Male
    Location
    Moving for free (requires Sun)
    Posts
    3,732
    Make sure the DJM has the same bitrate on the playback of your volume as you just configured in the DJM settings utility



    Now recording volume

    Is a bit of searching, recording, hearing if you have no noise in your recording, try and tweak it with the gain buttons on the DJM







    -will continue on next page-

  3. #3
    AH.FM Addict enRu's Avatar
    Join Date
    May 2010
    Gender
    Male
    Location
    Moving for free (requires Sun)
    Posts
    3,732
    Next Traktor Pro config for recording MIDI connection:

    Close Traktor
    Disconnect the USB cables
    Open Traktor
    Run the setup wizard in the settings of traktor
    Select external controller, yes, latest version has CDJ 2000 Nexus
    Select external mixer, at the time I write this guide there is no support for the DJM 2000 Nexus yet, regardless, just check number of CDJs you have and you're fine

    Close Traktor
    Power on & Connect USB of devices
    Open traktor

    In traktor set this as audio (might need to download asio drivers if not working)

    Note to use the same sample rate as set on the DJM playback on your volume,
    also note that 1920 buffer is set thanks to the configuration utility in the pioneer program files

    In traktor set the channels you want to use as output

    Note that this has NOTHING to do with the channel you chose on the CDJs when connecting (USB button).
    You will find USB1/2 or 3/4 on the top of your DJM. The switches on the DJM should thus for MIDI be set to USB and you select the channel you want to use. I use channel B & C on the DJM however I still use A and B on traktor + CDJ as I use 2 CDJs. all depends how you connect audio cables & specify it in traktor.

    In traktor set this as input



    If you got it working you might wanna export a tsi from traktor with the correct settings
    Last edited by enRu; Jul 5th, 2014 at 10:08.

  4. #4
    AH.FM Addict enRu's Avatar
    Join Date
    May 2010
    Gender
    Male
    Location
    Moving for free (requires Sun)
    Posts
    3,732
    Some tips

    Option 1 playing on party is different as MIDI recording, so never forget this

    - if using CDs instead of PC, did you put knobs back to CD top of the DJM?
    - if not working live, you might not wanna connect the DJM usb cable (only CDJs)
    - if you don't hear PFL, go in remix on the DJM
    - Traktor A & B is traktor, has nothing to do with connection to DJM (A can be deck B), notice usb 3/4 on deck B,
    this is what you would have to put on A in traktor however we use purely CDJ 1 en 2 for output.
    - 24 bit on the CDJ themselves?
    - select Vinyl on the CDJ (is better :p)

    Option 2 recording at home/studio

    - Did you put the knobs to USB on top of the DJM?
    - In device manager, uninstall DJM (somewhere) with yellow mark and delete drivers, disconnect DJM USB from computer, install driver, reconnect, let it find it.
    - IN CASE OF WINDOWS 8/8.1
    Install the old driver of DJM (1100) but notice in windows 8 you might need to go first to go in startup settings (advanced reboot) and disable driver signing (be sure what you are doing here, I will not explain to avoid problems, but this is the only way to install it)

    - note even if you disabled driver signing, the yellow marker DJM driver will come back each time, simple, uninstall & delete driver, disconnect DJM USB, reinstall with admin, reconnect, set 1920 cache first, 16 1 input again and open Traktor and tada.

    Pioneer goddamn fix it

    Not finding recording in traktor?

    - Top right corner of the program, switch from essential to extended

    Hope this helps for people having the same trouble I had, cheers !

    Now let's MIX !!
    Last edited by enRu; Jul 5th, 2014 at 10:00.

  5. #5
    AH.FM Addict enRu's Avatar
    Join Date
    May 2010
    Gender
    Male
    Location
    Moving for free (requires Sun)
    Posts
    3,732
    Sorry the pics are gone as they were on my old domain

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •